Day.png);">
Apprendre


Vous êtes
nouveau sur
Oniromancie?

Visite guidée
du site


Découvrir
RPG Maker

RM 95
RM 2000/2003
RM XP
RM VX/VX Ace
RM MV/MZ

Apprendre
RPG Maker

Tutoriels
Guides
Making-of

Dans le
Forum

Section Entraide

News: Les pommes de terre volent haut, (...) / Scripts: Old RPG Maker Style 1.12 / Jeux: NoRoi / Jeux: Dyhortfight chapitre 4 / Programmes: [2000-2003] EasyRPG Player / Chat

Bienvenue
visiteur !





Désactiver
la neige


publicité RPG Maker!

Statistiques

Liste des
membres


Contact

Mentions légales

120 connectés actuellement

26715078 visiteurs
depuis l'ouverture

1784 visiteurs
aujourd'hui



Barre de séparation

Partenaires

Indiexpo

Akademiya RPG Maker

Hellsoft

Planète Glutko

Lunae - le bazar d'Emz0

Le Studio du Chat Vert

Tashiroworld

RPG Maker - La Communauté

Tous nos partenaires

Devenir
partenaire



forums

Index du forum > Entraide > [RPG Maker 2003] Affichage des vidéos

Aller à la page 1 2 3 4


Sylvanor - posté le 21/06/2020 à 11:37:21 (23727 messages postés) - webmaster -

❤ 0

Le gars chiant qui rigole jamais (il paraît)

Domaine concerné: Compatibilité
Logiciel utilisé: RPG Maker 2003
Bon voilà je mets un sujet ici pour essayer d'avoir un peu plus de visibilité parce que ce problème m'ennuie beaucoup et j'ai cherché des heures sans trouver.

Tout a commencé avec un mail d'un joueur anglophone qui me dit qu'il joue à mon jeu mais que les cinématiques ne s'affichent pas. Il a le son de celles-ci, mais pas l'image: le jeu freeze pendant qu'elles se jouent, puis reprend quand elles sont terminées.
Je me dis bon, bizarre, je vais essayer sur mon nouvel ordi Windows 10 tiens et je constate que j'ai le même problème.

Lui, il a la version du jeu basée sur l'ancien RPG Maker, avec le moteur graphique à l'ancienne, et moi j'ai testé les deux versions, la même et celle que j'ai maintenant, basée sur la version Steam.

Constat: les vidéos s'affichent uniquement en mode plein écran de l'ancienne version, ou de la nouvelle lorsqu'on lui demande dans les options graphiques d'utiliser l'ancien moteur.
En mode fenêtré, et dans les deux modes du nouveau moteur (GDI), rien à faire les vidéos sont invisibles.

Bien sûr j'ai mis le codec MPEG-2, celui que je propose habituellement et qui résolvait le problème sur Windows 7 (celui-là).
J'en ai testé plein d'autres, mais aucun n'a réglé la situation.

C'est un gros problème si les gens ne peuvent plus voir les vidéos lorsqu'ils jouent à mon jeu, et si nous sommes déjà deux dans ce cas - alors que mon PC est encore tout neuf et n'a donc pas subi mille installations ou saletés - on peut penser que la plupart des gens seront dans ce cas et ça me préoccupe beaucoup.
L'ancien moteur graphique pose plein de problèmes et il faudrait pouvoir utiliser le nouveau.
Sur Windows 7 tout marchait, ancien et nouveau, en plein écran et en fenêtré.

Remarque:
En faisant des tests je me suis aperçu que les vidéos s'affichaient sur ma télé mais pas sur mon écran d'ordi.
Je pense être sur une piste car lorsque j'ai touché aux réglages de résolution et de couleurs ma télé a fini par ne plus les afficher non plus.
En fait je me suis aperçu qu'en demandant certaines résolutions pour ma télé, notamment des résolutions au-delà du 1080p, Windows lui envoie un signal en YCbCr 420 au lieu du RVB. Et dès que ce mode de couleurs est activé, les vidéos s'affichent. Cela me semble faire sens dans la mesure où les vidéos sont encodées en YCbCr 240.

Mais je ne peux pas exiger ce mode de couleurs, il faut que Windows décide de lui-même de l'utiliser.
Impossible de lui demander d'appliquer ce mode à mon écran de PC. Et, bien sûr, j'ai pensé à la solution de réencoder ces vidéos en RVB mais ce n'est pas possible je n'ai que ce mode de couleurs dans les paramètres d'encodage, je suppose qu'il est exigé par le format MPEG-2, auquel je dois me conformer pour RPG Maker 2003.
Les drivers Nvidia proposent bien de forcer un mode de couleurs, mais il n'offre que les options RVB, YcbCr 422 et 444, et aucun ne résout le problème.
Bon si ça se trouve je suis sur une mauvaise piste mais je me dis que c'est peut-être à chercher par là.
Vous me direz sur Windows 7 y avait pas besoin de faire tout ça.
En tous cas, le fait que la vidéo s'affiche sous certaines conditions d'affichage prouve que ce n'est pas un problème de codec. Enfin je suppose.

---------------------------
J'ai fait un petit projet de test tout léger à télécharger et à dézipper pour voir si chez vous les vidéos s'affichent: ICI.
Il y a juste à lancer le jeu et parler au cactus, la vidéo doit se lancer.
Ca m'intéresse surtout si vous êtes sur Windows 10. Téléchargez bien le codec si vous voulez faire l'essai.
---------------------------

Ce que je voudrais c'est trouver une méthode, ou bien trouver la bonne option, un patch, n'importe quoi qui permette de faire que ça marche, et pouvoir le proposer aux joueurs qui rencontrent ce problème (en plus de l'utiliser moi-même).

Les croissants croâssent en croix, s'ancrent ou à cent croîssent sans crocs à sang. Crois! Sens! ౡ


Kenetec - posté le 21/06/2020 à 11:52:09 (12710 messages postés)

❤ 0

~°~

Chez moi ça marche.©

Plein écran comme fenêtré.
En Windows 10.

Je n'ai pas installé les codecs mais c'est possible que je les avait déjà sur mon PC sans m'en rappeler.

Le Miroir de Philéas (Jeu complet)


Gari - posté le 21/06/2020 à 11:54:00 (5612 messages postés) - honor -

❤ 0

Pour moi ça fonctionne aussi pour les deux modes. En voulant tester la petite fenêtre (F5), je suis tombé sur ça :
image
Est-ce que c'est pareil chez toi ? Si ça se trouve, il s'agit juste d'une mauvaise adaptation à l'écran windows selon le mode.


Sylvanor - posté le 21/06/2020 à 12:09:42 (23727 messages postés) - webmaster -

❤ 0

Le gars chiant qui rigole jamais (il paraît)

Oui j'ai les mêmes réglages que toi Gari.
Bon, le fait que ça fonctionne chez vous est rassurant.

Mais il faut absolument trouver ce qui change entre votre config et la mienne.
Vos écrans sont bien en RVB? Sous Windows 10 vous pouvez le vérifier en allant dans Paramètres d'affichage et Paramètres d'affichage avancés.

Chez moi ça donne ça:

image

Kenetec est-ce que tu veux bien installer le codec juste pour vérifier qu'il ne crée pas de problème?
Tu pourras le désinstaller après (il suffit de relancer l'installeur et cliquer sur Remove).

Les croissants croâssent en croix, s'ancrent ou à cent croîssent sans crocs à sang. Crois! Sens! ౡ


Gari - posté le 21/06/2020 à 12:19:06 (5612 messages postés) - honor -

❤ 0

J'ai exactement le même machin (à part la carte graphique) :
image


Kenetec - posté le 21/06/2020 à 12:22:13 (12710 messages postés)

❤ 0

~°~

Mon écran est bien en RVB, j'ai les mêmes réglages que toi.

J'ai installé les codecs, et ça fonctionne toujours, plein écran comme fenêtré.

Seul plantage que j'ai, c'est quand je règle en DirectDraw, que je met en plein écran SANS les codecs installé.
Ça plante, "cette interface n'est pas pris en charge".
Je sais pas si ça t'aide.

Le Miroir de Philéas (Jeu complet)


Sylvanor - posté le 21/06/2020 à 12:32:33 (23727 messages postés) - webmaster -

❤ 0

Le gars chiant qui rigole jamais (il paraît)

Merci à vous deux.

Bon alors de mon côté j'ai fait un autre test, enfin concluant, sur la piste de la question que je t'ai posée: j'ai désinstallé le codec, et tout à coup ça a marché.
En fait quand le codec est désactivé, FFDShow que j'ai installé hier prend le relais (icône rouge dans la zone de notification) et la vidéo s'affiche. Avant la désinstallation du codec, l'icône rouge ne s'affichait pas.
Si je vire FFDShow, message d'erreur (le codec étant désinstallé n'est plus là pour faire le -mauvais- job) et la vidéo ne s'affiche plus.

Bon je suis pas sûr que ça ait correctement désinstallé parce que j'ai voulu le remettre pour être sûr et là il me dit que le codec est déjà installé... Et j'ai des messages d'erreur en voulant le supprimer. Mais comme j'avais un message d'erreur en lisant la vidéo je pense qu'il était bel et bien désinstallé.

Du coup je crois que j'ai bien une piste solide: ne pas installer le codec, juste mettre FFDShow.
Cela dit si vous n'avez pas FFDShow chez vous je ne sais pas ce qui fait que ça marche.
J'ai envoyé l'idée à mon correspondant anglophone, on va voir s'il la teste et si ça marche chez lui.

Les croissants croâssent en croix, s'ancrent ou à cent croîssent sans crocs à sang. Crois! Sens! ౡ


Kenetec - posté le 21/06/2020 à 12:35:20 (12710 messages postés)

❤ 0

~°~

La dernière version Steam de 2003 n'améliorait pas automatiquement la compatibilité avec les vidéos ? Sans besoin de codec ou ajout externe ?

Le Miroir de Philéas (Jeu complet)


Gari - posté le 21/06/2020 à 12:38:20 (5612 messages postés) - honor -

❤ 0

Si. Mais la version pas steam que l'anglophone a ne le faisait pas.
Je ne me rappelle pas avoir installé le codec, ni FDShow.


Sylvanor - posté le 21/06/2020 à 12:44:15 (23727 messages postés) - webmaster -

❤ 0

Le gars chiant qui rigole jamais (il paraît)

Je n'ai pas souvenir qu'il y avait support des vidéos sans codec pour la version Steam. Ca voudrait dire que RM a les codecs "en lui". En tous cas le fait que ça marche pas chez moi semble prouver qu'il ne les a pas.
C'est facile de voir si on a FFDShow puisqu'il affiche une ou plusieurs icônes dans la zone de notification quand une vidéo est lue par Directshow (ce qui est le cas de RPG Maker).
Si vous n'avez ni le codec ni FFDShow et que ça marche... Je comprends rien. Quelque part tant mieux hein. Mais ça voudrait dire que nativement il doit y avoir des réglages, des options à activer.
Ou bien vous avez des codecs ou des trucs comme ça qui se sont installés avec vos drivers de carte graphique, ou d'autres logiciels (c'est souvent le cas avec les logiciels de montage vidéo). Ou bien une version de DirectX un peu différente?

Les croissants croâssent en croix, s'ancrent ou à cent croîssent sans crocs à sang. Crois! Sens! ౡ


Kenetec - posté le 21/06/2020 à 12:56:00 (12710 messages postés)

❤ 0

~°~

Du coup j'ai essayé sur un autre PC Windows 10 ou RM n'a jamais été installé.
J'ai ajouté la ligne FullPackageflag=1 dans le ini pour lancer le jeu.

Sans les codes installés, en effet, ça plante, plein écran + fenêtré.

Une fois les codecs installés, c'est Ok, plein écran + fenêtré.

Le Miroir de Philéas (Jeu complet)


Gari - posté le 21/06/2020 à 13:01:29 (5612 messages postés) - honor -

❤ 0

Je saurais pas te dire, mais on dirait surtout que la version Steam n'utilise plus direct Draw mais GDI (?). Elle a rajouté des options pour les vidéos, mais après niveau codecs je ne saurai pas dire précisément.
Pour la version, j'ai la 12.

Spoiler (cliquez pour afficher)


Edit : Grillé par Kenetec.


Sylvanor - posté le 21/06/2020 à 13:23:50 (23727 messages postés) - webmaster -

❤ 0

Le gars chiant qui rigole jamais (il paraît)

Bon on s'en sort pas je croyais avoir résolu le problème avec FFDShow sauf que je ne peux visionner qu'une seule fois une vidéo.
Dès que je lance une deuxième vidéo après en avoir vu une première, j'ai le même problème qu'avant, l'écran se fige jusqu'à la fin de la lecture. Pourtant l'icône FFDShow rouge est présente dans la zone de notification.

C'est dingue ce truc.
Vous avez testé de voir deux fois d'affilée la vidéo en parlant deux fois au cactus?

Visiblement vous utilisez pas FFDShow mais moi sans lui, ça veut pas, soit j'ai le message d'erreur (sans le codec) soit j'ai le jeu qui se fige (avec le codec).

Les croissants croâssent en croix, s'ancrent ou à cent croîssent sans crocs à sang. Crois! Sens! ౡ


Gari - posté le 21/06/2020 à 13:36:57 (5612 messages postés) - honor -

❤ 0

J'ai testé plusieurs fois le cactus, et ça fonctionne tout pareil. Par rapport à DirectDraw, sur ce topic, ils parlent de Crossfire (un truc en lien avec les cartes graphiques), mais c'était pour Windows 8... Même conclusion ici, mais là encore le problème est général :/
Si vraiment tu penses qu'il manque des composants à DirectX, tu as un logiciel sur Microsoft pour rajouter des éléments manquants aux versions actuelles, permettant notamment d'améliorer la compatibilité avec des vieux jeux. Cependant, je pense pas que le problème vienne de là (ça n'avait pas résolu le problème de celui qui l'a essayé, d'ailleurs).


Sylvanor - posté le 21/06/2020 à 14:10:24 (23727 messages postés) - webmaster -

❤ 0

Le gars chiant qui rigole jamais (il paraît)

Je n'ai pas de Crossfire vu que j'ai une carte graphique Nvidia (et une seule).
J'ai testé le logiciel dont tu parles mais il s'arrête dès le début en me disant que j'ai une version plus récente de DirectX.

Les croissants croâssent en croix, s'ancrent ou à cent croîssent sans crocs à sang. Crois! Sens! ౡ


Gari - posté le 22/06/2020 à 13:18:37 (5612 messages postés) - honor -

❤ 0

Nonor, je t'ouvre un petit topic sur RMN, on verra bien si quelqu'un a une réponse pour ton problème. Cependant, je pense pas que ton problème soit RM mais un autre logiciel / antivirus / pare-feu qui interfère avec, ou un problème d'affichage à paramétrer.


Sylvanor - posté le 23/06/2020 à 19:56:23 (23727 messages postés) - webmaster -

❤ 0

Le gars chiant qui rigole jamais (il paraît)

Merci c'est gentil Gari.

Personne d'autre sinon?
Au moins essayer le petit projet de test que j'ai mis dans le premier post et me dire si la vidéo s'affiche correctement chez vous?

Les croissants croâssent en croix, s'ancrent ou à cent croîssent sans crocs à sang. Crois! Sens! ౡ


Mack - posté le 23/06/2020 à 20:20:16 (2211 messages postés)

❤ 0

RAS pour moi la vidéo se lance bien, en plein écran, comme en fenêtré :/

( Je prend note de tout les commentaires, même si je n'y répond pas )


trotter - posté le 23/06/2020 à 21:55:24 (9929 messages postés) -

❤ 0

Avec le codec j'ai le jeu qui freeze, un bruit de vague/explosion/transition dimensionnelle, un flash noir d'une demi seconde et puis le bruit s'arrête et le jeu refonctionne.

image

La vidéo ne se lit pas non plus sur le lecteur windows media player.

Version de windows :
image

J'ai changé de PC ya pas longtemps également.


Maluska78 - posté le 23/06/2020 à 22:22:15 (1 messages postés)

❤ 0

Salut !

Sur le mini projet, je peux lancer que 1 fois la vidéo, la seconde fois, la vidéo ne s'affiche pas (uniquement le son ...)

Sur Windows10 également pour moi ...


Dobiscuss - posté le 24/06/2020 à 14:01:53 (86 messages postés)

❤ 0

Salut Sylvanor.

J'ai dans un premier temps installé le codec que tu as fourni. Je n'ai pas RPG Maker donc je n'ai pas pu démarrer le projet mais j'ai ouvert la video avec l'application Film et TV sous Windows.

La vidéo n'affichait rien, mais Film et TV m'a proposé de télécharger le codec "Extension vidéo MPEG-2" sur le Windows Store. Une fois installé, j'ai pu lire la vidéo correctement avec Film et TV.

La vidéo fonctionne avec VLC et MPC-HV (Media Player Classic Home Video). Par contre, elle ne se lit pas avec le Lecteur Windows Media Player.

J'espère que ça pourra un peu t'aider.

La fleur d'un bouquet fane ... MAIS JAMAIS NE RENAIT !!!


Gari - posté le 24/06/2020 à 14:08:37 (5612 messages postés) - honor -

❤ 0

Ca me fait penser... peut-être que ta dll mpeg-2 n'est pas compatible avec windows 10. Il en existe sans doute une version plus récente.


trotter - posté le 24/06/2020 à 15:21:48 (9929 messages postés) -

❤ 0

Ca marche chez toi Sylvanor avec le lecteur Windows Media Player ?
Et chez toi Kenetec ?


Gari - posté le 24/06/2020 à 15:33:43 (5612 messages postés) - honor -

❤ 0

Ca marche pas sur Windows Media Player chez tous ceux qui ont le bug. Je suis dans le cas de Kenetec (où ça fonctionne sur RM), et j'ai tenté sur WMP, mais le lecteur crash au bout de quelques secondes (le son et l'image sont bien présents, c'est sans doute mon pc qui a du mal => en convertissant avec un logiciel d'essai, la vidéo fonctionne sans heurt avec wmp, cependant). Après, j'ai changé quelques codecs pour améliorer le fonctionnement de VLC. Et WMP ne supporte que les codecs de vidéos standards de chez Windows, donc c'est peut-être normal.


Dobiscuss - posté le 24/06/2020 à 16:22:48 (86 messages postés)

❤ 0

Bon j'ai télécharger Media Player Codec Pack pour Windows sur Clubic. Maintenant la vidéo se lance correctement mais fait geler le lecteur en fin de vidéo. Si je ferme WMP et que j'ouvre à nouveau la vidéo sous WMP, même résultat : lecture de la vidéo et son et plantage du lecteur à la dernière seconde.

La fleur d'un bouquet fane ... MAIS JAMAIS NE RENAIT !!!

Aller à la page 1 2 3 4

Index du forum > Entraide > [RPG Maker 2003] Affichage des vidéos

repondre up

Suite à de nombreux abus, le post en invités a été désactivé. Veuillez vous inscrire si vous souhaitez participer à la conversation.

Haut de page

Merci de ne pas reproduire le contenu de ce site sans autorisation.
Contacter l'équipe - Mentions légales

Plan du site

Communauté: Accueil | Forum | Chat | Commentaires | News | Flash-news | Screen de la semaine | Sorties | Tests | Gaming-Live | Interviews | Galerie | OST | Blogs | Recherche
Apprendre: Visite guidée | RPG Maker 95 | RPG Maker 2003 | RPG Maker XP | RPG Maker VX | RPG Maker MV | Tutoriels | Guides | Making-of
Télécharger: Programmes | Scripts/Plugins | Ressources graphiques / sonores | Packs de ressources | Midis | Eléments séparés | Sprites
Jeux: Au hasard | Notre sélection | Sélection des membres | Tous les jeux | Jeux complets | Le cimetière | RPG Maker 95 | RPG Maker 2000 | RPG Maker 2003 | RPG Maker XP | RPG Maker VX | RPG Maker VX Ace | RPG Maker MV | Autres | Proposer
Ressources RPG Maker 2000/2003: Chipsets | Charsets | Panoramas | Backdrops | Facesets | Battle anims | Battle charsets | Monstres | Systems | Templates
Ressources RPG Maker XP: Tilesets | Autotiles | Characters | Battlers | Window skins | Icônes | Transitions | Fogs | Templates
Ressources RPG Maker VX: Tilesets | Charsets | Facesets | Systèmes
Ressources RPG Maker MV: Tilesets | Characters | Faces | Systèmes | Title | Battlebacks | Animations | SV/Ennemis
Archives: Palmarès | L'Annuaire | Livre d'or | Le Wiki | Divers